I seek answers for my Linux problem.

I really love linux, i've been dual booting linux from windows 10 home edition since atleast 1 year now and i mostly use Arch linux and Arch based distributions, but i've used ubuntu based and more, everything works like a charm apart from one thing, putting my computer in suspend mode and starting it the next day breaks the distro i use, same with shutdowning it and opening it again breaks them, i cannot access the tty cmd line after booting from grub, every issue i saw on other forums and wikias only described my problem when they had access to the tty, i've had this problem with every distro i have tried yet.

, i wanted to know if there is a potential fix for this problem, and if i simply install Arch completely instead of dual booting might fix the issue aswell. I also tried to run a linux distro in a Oracle virtual box and unsuprisingly, it worked fine on the VM, maybe it's my computer, i disabled fast boot and secure boot aswell. That's all, thanks in advance. It may also be that a prebuilt pc with windows isnt meant to run Linux 

ACPI x64-based PC

info on pc : Processor - Intel(R) Core(TM) i5-6400 CPU @ 2.70GHz 4-cores

: 1TB Hybrid Hark Disk + 8gb SSD / GPU : NVIDIA GeForce GTX 960

On windows, i have 1 partition for windows installation that is 149GB large, another partition that is my Data partition 778Gb large where i stock all my games videos etc, and another partition for efi system partition which is 100 mb large, also recovery partition 886 mb large and another one i made myself because not enough efi is EFI System partition which is 2gb for boot.

edit: Thanks for all the quick answers, i appreciate it. My problem is now fixed

Sign In or Register to comment.